Next: , Up: Installation

7.1 What else do I need?

To compile Octave, you will need a recent version of GNU Make. You will also need g++ 2.7.2 or later. Version 2.8.0 or egcs 1.0.x should work. Later versions may work, but C++ is still evolving, so don't be too surprised if you run into some trouble.

It is no longer necessary to have libg++, but you do need to have the GNU implementation of libstdc++. If you are using g++ 2.7.2, libstdc++ is distributed along with libg++, but for later versions, libstdc++ is distributed separately. For egcs, libstdc++ is included with the compiler distribution.

<em>You must have gnu make to compile octave</em>. Octave's Makefiles use features of GNU Make that are not present in other versions of make. GNU Make is very portable and easy to install.